HBO Go at Rice University | Vendor Maintenance

Incident Report for Rice University

Resolved

This incident has been resolved.
Posted Aug 05, 2020 - 14:11 CDT

Monitoring

The Rice HBO Go service for on-campus students will be unavailable beginning July 31, 2020. The vendor is performing maintenance and upgrade to this service. Subscribe to IT Status: https://status.rice.edu for updates.
Posted Jul 31, 2020 - 15:09 CDT
This incident affected: Other (Announcements).