Delivery to Outside Email account domains impacted.
Incident Report for Rice University
Resolved
At this time, our mail servers are not blacklisted by any of the major blacklist services. We will resolve this incident, but continue to monitor the situation.
Posted Apr 06, 2020 - 08:38 CDT
Update
We are continuing to monitor for any further issues.
Posted Apr 04, 2020 - 14:20 CDT
Monitoring
We are having identified additional blacklists and are working to clear them.
128.42.201.30 Mail Handler was sourced as sender.
Posted Apr 03, 2020 - 16:10 CDT
Identified
We have been blacklisted again, due to another compromised Email account.
Emails sent to some outside domains like live.com, msn.com, hotmail.com and outlook.com are being blocked.
Removal from the public mail delivery blacklists takes time. Please wait and try re-sending your messages.
Posted Apr 03, 2020 - 09:57 CDT
Monitoring
Email is now being delivered normally again and we are monitoring the situation.
The emails being blocked were being sent to outside domains like: live.com, msn.com, hotmail.com and outlook.com.
Email to rice.edu addresses was not being blocked.
Posted Apr 02, 2020 - 19:07 CDT
Identified
We are having identified additional blocks and are working to clear them.
Posted Apr 02, 2020 - 16:13 CDT
Monitoring
We believe that Email is now being delivered normally and are monitoring the situation.
Posted Apr 02, 2020 - 14:30 CDT
Update
We are continuing to work on a fix for this issue.
Posted Apr 02, 2020 - 11:39 CDT
Identified
Due to a SPAM sent from a compromised computer Email account, sent to some outside domains like live.com, msn.com, hotmail.com and outlook.com is being blocked. Removal from the public mail delivery blacklists takes time. Please wait and try re-sending your messages.
Posted Apr 02, 2020 - 10:59 CDT
This incident affected: Email, Collaboration and Storage (Mail Blacklists).