Box Services Unavailable
Incident Report for Rice University
Resolved
Resolved - Resolved - The monitoring period has ended and no further impact has been observed. We are considering this issue resolved.
Posted Nov 02, 2018 - 19:30 CDT
Update
We are continuing to investigate this issue.
Posted Nov 02, 2018 - 17:02 CDT
Investigating
Box is currently investigating reports of the inability to access Box Services. They will provide more information as soon as it is available. https://status.box.com/
Posted Nov 02, 2018 - 16:49 CDT
This incident affected: Email, Collaboration and Storage (Box Drive, Box Mobile, Box Web Application).