Notice: Campus Authentication System - Brief Outage

Incident Report for Rice University

Update

We are continuing to monitor for any further issues.
Posted Jun 30, 2026 - 10:21 CDT

Monitoring

TS&S teams are actively working to restore services as quickly as possible and continue to monitor the environment. We appreciate your patience and will continue to provide updates as warranted.
Posted Jun 30, 2026 - 10:19 CDT

Identified

TS&S teams are actively engaged with service providers to identify the root cause and restore services as quickly as possible.
Posted Jun 30, 2026 - 10:17 CDT

Investigating

Rice TS&S is currently investigating a service disruption affecting our Web Single Sign-On (SSO). This disruption may temporarily limit access to applications and services.
Posted Jun 30, 2026 - 10:16 CDT
This incident affects: Accounts and Access (Authentication and Authorization Services).