Microsoft 365 - Issue with reading email messages in Outlook.
Incident Report for Rice University
Resolved
Per Microsoft Update:
We've finished the deployment of our fix and we've confirmed via monitoring and user reports that the issue has been mitigated.
Users will be required to restart their applications for the changes to take effect.
Posted May 13, 2021 - 09:51 CDT
Monitoring
Monitoring Microsoft Forums and Admin Center for problem updates.
Posted May 11, 2021 - 16:36 CDT
Identified
Microsoft is working on a resolution and we will continue to provide updates as MS provides them.
Posted May 11, 2021 - 16:35 CDT
Investigating
Microsoft has reported the issue:
We’re investigating an issue with email message visibility in Outlook. Outlook on the web appears to be unaffected.

All Exchange Online users should use Outlook on the Web (OWA), rather than the Outlook client; until Microsoft resolves the issue
Posted May 11, 2021 - 16:34 CDT
This incident affected: Email, Collaboration and Storage (Exchange Mail and Calendar).