Partial Network Outage | Cambridge Office Building 4th Floor

Incident Report for Rice University

Resolved

This incident has been resolved.
Posted Mar 21, 2025 - 11:34 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 21, 2025 - 11:22 CDT

Investigating

We are currently investigating this issue.
Posted Mar 21, 2025 - 10:56 CDT
This incident affected: Network and Connectivity (Wireless, Wired).