Network Outage | George R. Brown Hall (East)

Incident Report for Rice University

Resolved

This incident has been resolved. Replaced a failed component on the network switch.
Posted May 24, 2026 - 23:38 CDT

Investigating

We are currently investigating this issue.
Posted May 24, 2026 - 19:33 CDT
This incident affected: Network and Connectivity (Wireless, Wired).