Tennis and Rice Stadium network outage due to power

Incident Report for Rice University

Identified

The issue has been identified and a fix is being implemented.
Posted Jun 28, 2026 - 08:49 CDT

Investigating

We are currently investigating this issue.
Posted Jun 28, 2026 - 08:48 CDT
This incident affects: Network and Connectivity (Wireless, Wired).