Verizon Wireless Issues Affecting Campus Users

Incident Report for Rice University

Resolved

According to Verizon "The outage has been resolved. If customers are still having an issue, we encourage them to restart their devices to reconnect to the network. We sincerely apologize for the disruption."
Posted Jan 15, 2026 - 07:08 CST

Investigating

We have received multiple reports of issues with Verizon Wireless service on and around campus. The issue has been reported to Verizon, and has been escalated to outage status.

We will post updates as we learn more.
Posted Jan 14, 2026 - 13:30 CST