Sending email from legacy organizational accounts (Cyrus)

Incident Report for Rice University

Resolved

This incident has been resolved.
Posted Apr 23, 2026 - 19:56 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 23, 2026 - 14:38 CDT

Investigating

We have received reports of users not able to send mail from legacy org accounts on the Cyrus mail system. Org accounts on Google or Exchange are not affected. We are currently investigating the issue.
Posted Apr 23, 2026 - 13:44 CDT
This incident affected: Email, Collaboration and Storage (Cyrus (Campus) Mail System).