Emergency maintenance to Rice web sites and services

Incident Report for Rice University

Monitoring

The switch to the redundant application load balancer system is complete. We are continuing to monitor the situation.
Posted May 15, 2026 - 09:46 CDT

Investigating

TS&S is investigating issues with our application load balancers, Access to some Rice web services, sites and applications may be temporarily disrupted while we switch over to redundant system.
Posted May 15, 2026 - 08:48 CDT
This incident affects: Other (Announcements).