Power disruption at Stadium, IBC bldg, and Child Care Center caused network switches to reboot

Incident Report for Rice University

Resolved

Resolving this incident. Power has been stable since 12 AM
Posted Mar 20, 2025 - 07:25 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 19, 2025 - 23:50 CDT

Update

Another power blip in the same area has caused another reboot sequence. We continue to monitor the situation.
Posted Mar 19, 2025 - 23:50 CDT

Identified

A short power disruption at the Stadium, IBC bldg, and Child Care Center caused the network switches to reboot. All network devices have returned to normal operations. If you have any connectivity issues in these areas, please get in touch with the Helpdesk at help@rice.edu
Posted Mar 19, 2025 - 23:46 CDT
This incident affected: Network and Connectivity (Wireless, Wired).