Investigating loss of network services in Duncan, Lovett, Baker College
Incident Report for Rice University
Resolved
This incident has been resolved.
Posted Apr 01, 2020 - 16:05 CDT
Monitoring
Due to power loss on campus. Services have been restored.
Posted Apr 01, 2020 - 13:17 CDT
Investigating
We are currently investigating this issue.
Posted Apr 01, 2020 - 12:53 CDT
This incident affected: Network and Connectivity (Wireless, Wired).