Canvas outage

Incident Report for Rice University

Update

Canvas is experiencing a global outage affecting all Rice and Continuing Studies users. For the most up-to-date information, please visit the Instructure (Canvas) Statuspage at https://status.instructure.com/
Posted May 07, 2026 - 17:07 CDT

Identified

Canvas is undergoing emergency maintenance. We are currently monitoring the outage, and will provide updates when available.
Posted May 07, 2026 - 15:50 CDT
This incident affects: Teaching and Learning (Canvas Catalog, Canvas Learning Management System).