Canvas was experiencing issues due to an AWS incident. Canvas is now accessible.

Incident Report for Rice University

Resolved

This incident has been resolved.
Posted Oct 21, 2025 - 07:44 CDT

Monitoring

Canvas is now accessible, and we and Canvas engineers are monitoring for stability.

For ongoing updates, please visit https://health.aws.amazon.com/health/status as well as Canvas's status page at https://status.instructure.com/
Posted Oct 20, 2025 - 18:23 CDT

Identified

Canvas is currently experiencing a service disruption due to a widespread outage at Amazon Web Services (AWS). For ongoing updates, please visit https://health.aws.amazon.com/health/status as well as Canvas's status page at https://status.instructure.com/
Posted Oct 20, 2025 - 09:50 CDT
This incident affected: Teaching and Learning (Canvas Catalog, Canvas Learning Management System, Course Video Support).