Comcast/Xfinity Service Outage May Impact Teleworkers

Incident Report for Rice University

Resolved

The issue appears to be mostly resolved in the Houston area, with some intermittent issues still possible. Please confirm status in your area directly with your provider.
Posted May 02, 2025 - 20:49 CDT

Monitoring

Carrier has identified the cause as "network damage", and the current estimated time of restoration is 5/2/25, 4:00 p.m. CDT.

There are some reports of services being restored in the Houston area.
Posted May 02, 2025 - 12:28 CDT

Investigating

We are aware of a large-scale service outage currently affecting Comcast/Xfinity customers. This outage may impact the ability of some teleworkers to connect to Rice University resources from off campus.

Our team is actively monitoring the situation and will provide updates as they become available.
Posted May 02, 2025 - 11:32 CDT