Building access control system (CBORD) disruption

Incident Report for Rice University

Monitoring

The issue affecting building control access has been identified and resolved. TS&S will continue to monitor and verify stability.
Posted May 04, 2026 - 14:46 CDT

Investigating

Rice is currently experiencing a disruption to our building access control system (CBORD), resulting in blocked access to buildings that require ID cards or keypad entry.
TS&S is actively engaged with service providers to identify the root cause and restore consistent services as quickly as possible. We appreciate your patience and will continue to provide regular updates.
Posted May 04, 2026 - 14:29 CDT
This incident affects: Accounts and Access (Rice ID Card Services).