Partial network outage due to localized power outage

Incident Report for Rice University

Resolved

Power has remained stable at these locations, and network connectivity is fully operational.
Posted Mar 11, 2026 - 13:00 CDT

Monitoring

Power has been restored, and networking services are returning to normal. We will keep the incident open and monitor for stability for the next hour.
Posted Mar 11, 2026 - 11:59 CDT

Investigating

A power outage is impacting network services at IBC Bank Building, Morningside, and the Rice Child Care locations. We will post updates as the situation evolves.
Posted Mar 11, 2026 - 11:55 CDT
This incident affected: Network and Connectivity (Wireless, Wired).