Internet Border Emergency Change

Incident Report for Rice University

Resolved

This incident has been resolved.
Posted Jun 25, 2025 - 19:45 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 25, 2025 - 15:57 CDT

Investigating

Network Services will be making a change to our internet border. This change may or may not fix the current email issue. Increased latency will be experienced, but no downtime is expected.
Posted Jun 25, 2025 - 15:52 CDT
This incident affected: Network and Connectivity (Campus Connectivity, Internet Access, External Firewall).