Partial Campus Power Outage Affecting Multiple Buildings

Incident Report for Rice University

Resolved

Power has been restored and network devices are stable.
Posted Apr 21, 2025 - 19:20 CDT

Update

Network services have been restored at Rice Village Townhomes and Rice Village Apartments. A technician has been dispatched to check on some redundant equipment that has not recovered, but services are not impacted at this time.
Posted Apr 21, 2025 - 16:47 CDT

Monitoring

Power has been restored to most of campus, and network equipment is connected. As of this update, the following locations are still down:

Rice Village Apartments
Rice Village Townhomes
Posted Apr 21, 2025 - 16:26 CDT

Identified

The following locations appear to be impacted at this time:

Reckling Park
BRC (BioScience Research Collaborative)
Tudor Field House
Moody Center for the Arts
RUPD/ROTC Annex Building
Rice Village Apartments
South Plant
Soccer
Posted Apr 21, 2025 - 15:44 CDT

Investigating

We are currently investigating a partial campus power outage affecting multiple buildings. Updates will be posted.
Posted Apr 21, 2025 - 15:42 CDT
This incident affected: Network and Connectivity (Wireless, Wired).