Google Gemini Unresponsive

Incident Report for Rice University

Update

We are continuing to investigate this issue.
Posted Jun 10, 2026 - 09:26 CDT

Investigating

Google has confirmed that some Gemini customers are receiving error codes or a unresponsive experience with the Gemini LLM. Their engineering teams are currently investigating the issue. TS&S will update this Statuspage in alignment with them.
Posted Jun 10, 2026 - 09:25 CDT