Network Services | Power Outages at Stadium

Incident Report for Rice University

Resolved

Power issues at the Stadium have been resolved. All networking equipment is online and operational.
Posted May 04, 2026 - 14:12 CDT

Investigating

Users are currently experiencing limited or complete loss of network connectivity at Rice Stadium and the immediate surrounding areas. Network Services is actively investigating the outage and suspects a potential power issue. A request has been submitted to Facilities to check the power supply in the area, and we will provide an update once more information is available.
Posted May 04, 2026 - 11:46 CDT
This incident affected: Network and Connectivity (Wireless, Wired).