Mudd GPlotter Out of Service

Incident Report for Rice University

Resolved

This incident has been resolved
Posted Dec 08, 2025 - 11:48 CST

Identified

A hardware failure has been identified, and we are actively working with the vendor to expedite the replacement of the defective components.
Posted Dec 01, 2025 - 10:49 CST