Mail Blocklists - delivery to outside domains impacted
Incident Report for Rice University
Resolved
At this time, our mail servers are not blocklisted by any of the major blocklist services. We will resolve this incident, but continue to monitor the situation.
Posted Jul 29, 2020 - 18:56 CDT
Identified
Emails sent to outside hosted domains are being blocked. Some reported domains include: yahoo.com, aol.com, kelseyseybold.com. Removal from outside mail delivery blocklists takes time. Please wait a bit and try re-sending your messages.

If you have any questions, please contact the OIT Help Desk: helpdesk@rice.edu or 713-348-4357.
Posted Jul 24, 2020 - 11:38 CDT
This incident affected: Other (Announcements).