Power was restored to the affected areas at 6:35 p.m. Network equipment has been confirmed to be back online and functioning.
Posted Jan 06, 2026 - 19:13 CST
Update
No ETA on Centerpoint power restoration. Rice Facilities is onsite investigating alternative power options.
Posted Jan 06, 2026 - 16:19 CST
Update
We are experiencing power loss to some of the tennis court cameras, specifically courts 1, 3, and 6.
Posted Jan 06, 2026 - 14:14 CST
Update
The Pressbox network batteries have expired. Connectivity will remain down until power is restored.
Posted Jan 06, 2026 - 14:01 CST
Identified
There are 4 network switches in the Stadium that are currently on battery power. Connectivity service to the R-room and the Pressbox will be impacted when/if the UPS batteries expire before the repair of the Centerpoint circuit is complete.
Parking gates 55 and 57 are also impacted by this.
Posted Jan 06, 2026 - 13:34 CST
Investigating
A contractor may have cut a CenterPoint feed into Rice Stadium. OIT is investigating.
Posted Jan 06, 2026 - 13:05 CST
This incident affected: Network and Connectivity (Wireless, Wired).