banner systems inaccessible

Incident Report for Rice University

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 24, 2026 - 20:15 CDT

Investigating

We are currently investigating this issue.
Posted Jun 24, 2026 - 17:51 CDT
This incident affects: Student Systems (Degree Works, Edgar, Esther, Banner - Student).