Residential Wireless Network Outage

Incident Report for Rice University

Resolved

Residential wireless services have been stabilized following the resolution of last night’s connectivity issue. We will continue to monitor the network closely throughout the day. We appreciate your patience as we worked to restore services.
Posted Feb 18, 2026 - 12:27 CST

Monitoring

Wireless networking services have returned to an operational state. We will continue to investigate the root cause.
Posted Feb 17, 2026 - 22:06 CST

Investigating

Network Services is currently investigating a wireless network outage impacting residential wireless services.
Posted Feb 17, 2026 - 21:10 CST
This incident affected: Network and Connectivity (Wireless).