Canvas Log In/Timeout Issues

Incident Report for Rice University

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 21, 2026 - 16:45 CDT

Investigating

Canvas has been experiencing sporadic slowness and timeout errors, beginning at 12:11 PM on April 21, 2026. If you are still experiencing issues logging in, please clear your browser's cache and cookies or open a new incognito window. Then try logging in again.
Posted Apr 21, 2026 - 16:41 CDT
This incident affects: Teaching and Learning (Canvas Learning Management System).