Partial Campus Power Issue Affecting Network Services

Incident Report for Rice University

Resolved

This incident has been resolved.
Posted Mar 16, 2025 - 09:44 CDT

Investigating

Multiple buildings across campus experienced what appears to be a brief power outage at approximately 9:10 a.m. Network services in the following buildings are impacted at this time:

Herman Brown Hall
Martel College
Herring Hall
Baker College
Allen Center
McNair Hall
Duncan Hall
Facilities and Engineering
Jones College
Hanzen College
Humanities
Fondren Library
South West Servery
Will Rice College
Wiess College
Ryon Engineering Lab
Brockman Physics
Keck Hall
Rice Memorial Center
Oshman Engineering Design Kitchen
South West Servery
Posted Mar 16, 2025 - 09:30 CDT
This incident affected: Network and Connectivity (Wireless, Wired).