Degree Works currently experiencing issues
Incident Report for Rice University
Resolved
This incident has been resolved.
Posted Jul 15, 2020 - 16:12 CDT
Update
Degree Works is now back online. Thank you for your patience.
Posted Jul 15, 2020 - 16:12 CDT
Investigating
Sorry for the inconvenience. We are currently investigating this issue.
Posted Jul 15, 2020 - 15:59 CDT
This incident affected: Enterprise Systems (Degree Works).