Rice Webmail [webmail.rice.edu] is intermittently unavailable.
Incident Report for Rice University
Resolved
The issue with webmail.rice.edu has been resolved.
If you are still experiencing service issues, please contact the OIT Help Desk, https://oit.rice.edu/request-help
Posted Aug 17, 2018 - 18:17 CDT
Investigating
Some Rice faculty, staff, and graduate students are experiencing issues with Rice Webmail. Rice OIT is currently investigating and will update as soon as possible.
Posted Aug 17, 2018 - 14:56 CDT
This incident affected: Email, Collaboration and Storage (Rice Webmail).