Campus Power Outage

Incident Report for Rice University

Resolved

This incident has been resolved.
Posted Dec 12, 2025 - 16:41 CST

Monitoring

Power is back on across campus. IT services are online and available. Should you experience issues, contact the OIT Help Desk, at help@rice.edu or 713-348-HELP.
Posted Dec 12, 2025 - 15:00 CST

Identified

The campus has lost power. Buildings and systems without backup power may be offline. IT services, including iO, Banner, email, and general web services, are still online and available.
Posted Dec 12, 2025 - 14:40 CST