IBC | Loss of Wired / Wireless Network connectivity due to electrical issues

Incident Report for Rice University

Resolved

Electricity has been restored, and networking equipment is back online
Posted Jul 08, 2026 - 10:47 CDT

Monitoring

Electricity has been restored, and networking equipment is back online
Posted Jul 08, 2026 - 10:47 CDT

Investigating

We are currently investigating this issue.
Posted Jul 08, 2026 - 10:46 CDT
This incident affected: Network and Connectivity (Internet Access, Wireless, Wired).