Issues with connecting to Rice VPN

Incident Report for Rice University

Resolved

This incident has been resolved.
Posted May 08, 2025 - 22:38 CDT

Update

Load balancer services experienced an outage, affecting several services, including Single-Sign-On (SSO). Services have been restored, and we are monitoring
Posted May 08, 2025 - 22:04 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 08, 2025 - 21:58 CDT

Investigating

We are currently investigating this issue.
Posted May 08, 2025 - 21:17 CDT
This incident affected: Network and Connectivity (Campus Connectivity).