Duo - Degraded Performance
Incident Report for Rice University
Resolved
This incident has been resolved.
Posted Jan 10, 2019 - 17:21 CST
Investigating
Duo Security is reporting an elevated level of slow or failed authentication requests. They are continuing to monitor the situation.

https://status.duo.com/
Posted Jan 10, 2019 - 15:28 CST
This incident affected: Accounts and Access (Authentication and Authorization Services) and Network and Connectivity (VPN (Virtual Private Network)).