Partial Service Outage - Verizon Wireless Inbound Calls

Incident Report for Rice University

Resolved

On 2026-02-18 at 02:45:20 GMT, Rice University's Local Exchange Carrier received confirmation from Verizon that the issue should now be resolved. Network Services has successfully tested services throughout the morning and mid-day peak hours. We are resolving this issue; please advise if you continue to experience service degradation.
Posted Feb 18, 2026 - 12:07 CST

Investigating

The Office of Information Technology (OIT) has become aware of a partial service outage affecting inbound Verizon Wireless calls to the campus phone system.

Current Status:
• Inbound Calls: Currently, approximately 50% of incoming calls from Verizon Wireless callers are failing to connect.
• Outbound Calls: Calls placed from campus landlines to external numbers appear to be functioning normally.
• Other Carriers: Calls from providers other than Verizon appear to be unaffected at this time.

OIT is actively monitoring the situation and will post updates as we become aware.
Posted Feb 17, 2026 - 15:43 CST