Request Tracker Online

Incident Report for Rice University

Update

While RT is now online, we are continuing to investigate the reason for disruption and will keep this status page up to provide further updates.
Posted Jun 07, 2025 - 11:02 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 07, 2025 - 08:22 CDT

Investigating

We are currently investigating this issue.
Posted Jun 07, 2025 - 07:04 CDT