Issue with Box Drive
Incident Report for Rice University
Resolved
Per Box vendor, their teams have validated that all affected services are recovered at this time. No additional impact has been observed and this incident is now considered Resolved.
Posted Sep 07, 2024 - 10:52 CDT
Investigating
The Box vendor is reporting an issue with Box Drive and some users may see delayed updates synchronizing items from the Box Web App to Box Drive desktop clients. The vendor is currently investigating the issue.
Posted Sep 06, 2024 - 12:24 CDT
This incident affected: Email, Collaboration and Storage (Box Drive).