help.rice.edu (RT) Down

Incident Report for Rice University

Resolved

This incident has been resolved.
Posted May 15, 2026 - 09:43 CDT

Monitoring

The helpdesk system is now operational. We are still monitoring.
Posted May 15, 2026 - 06:24 CDT

Investigating

The helpdesk system is inaccessible. We are investigating.
Please call the helpdesk directly @ 7133484357
Posted May 15, 2026 - 06:06 CDT
This incident affected: Web and Applications (Request Tracker).