OnBase temporarily unavailable
Incident Report for Rice University
Resolved
This incident has been resolved.
Posted Sep 27, 2022 - 11:20 CDT
Update
OnBase is operational again.
Posted Sep 27, 2022 - 11:19 CDT
Update
We are continuing to investigate this issue.
Posted Sep 26, 2022 - 19:22 CDT
Investigating
We are currently investigating this issue.
Posted Sep 26, 2022 - 19:21 CDT