Request Tracker Unavailable

Incident Report for Rice University

Resolved

Request Tracker has remained stable and therefore we are resolving the incident.
Posted Jun 27, 2025 - 17:08 CDT

Monitoring

The system is back online and we're monitoring for stability.
Posted Jun 27, 2025 - 13:06 CDT

Investigating

We are investigating an outage related to Request Tracker and will provide updates as we learn more.
Posted Jun 27, 2025 - 12:59 CDT