Partial Internet Connectivity Outage – Dynamic One Building

Incident Report for Rice University

Resolved

This incident has been resolved.
Posted May 29, 2025 - 12:55 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 29, 2025 - 10:04 CDT

Investigating

We are currently experiencing an issue with one of our redundant commodity internet connections due to a power failure at an upstream provider. As a result, off-campus connectivity for the Dynamic One building is impacted. All other campus locations remain unaffected and are operating normally.

Our team is actively working with the provider to restore service as quickly as possible. We will provide updates as more information becomes available.
Posted May 29, 2025 - 09:30 CDT
This incident affected: Network and Connectivity (Internet Access, Wireless, Wired).