Tableau Server (dataviz.rice.edu) is currently unavailable.

Incident Report for Rice University

Postmortem

Summary

On April 18, 2026, Tableau Server experienced an outage following Windows updates applied to the VM server. After troubleshooting, the issue was traced to the Tableau Server license state. The Windows updates triggered a change that caused Tableau to stop recognizing the existing licensing tied to the server’s SID and hardware profile. Service was restored after the Tableau Server license key was reactivated.

Impact

  • Tableau Server was unavailable during the outage period
  • Users were unable to access dashboards and published content
  • Scheduled refreshes and other Tableau Server-dependent processes were interrupted until service was restored

Root Cause

The outage was caused by Windows updates performed on the Tableau VM server. Following the updates, Tableau Server encountered a licensing issue related to SID and hardware-based license validation. As a result, Tableau Server services did not start normally until the license key was restored.

Resolution

  • Investigated the Tableau Server failure after the VM updates
  • Identified the issue as a Tableau licensing problem
  • Restored the Tableau Server license key
  • Confirmed Tableau Server services returned to normal operation

Preventive Actions

Moving forward, we will:

  • Request advance notification from the VM server administrators before Windows updates are applied to the Tableau VM
  • Coordinate update timing to reduce the risk of unexpected service disruption
  • Include a Tableau licensing check as part of post-update validation when server maintenance occurs
  • Review whether any additional Tableau-specific safeguards or documentation should be added to the maintenance process

Lessons Learned

This incident showed that Windows updates on the VM can affect Tableau Server licensing and availability. Better coordination before infrastructure changes will help reduce downtime and improve recovery time if similar issues occur again.

Posted Apr 18, 2026 - 10:01 CDT

Resolved

Tableau Server is now available.
Posted Apr 18, 2026 - 09:50 CDT

Update

We are continuing to investigate this issue.
Posted Apr 18, 2026 - 09:47 CDT

Investigating

Tableau Server is currently down. Our team is actively investigating the issue and working on a resolution. We will provide updates as more information becomes available.
Posted Apr 18, 2026 - 08:24 CDT
This incident affected: Enterprise Systems (Tableau).