Proofpoint Services Degraded

Incident Report for Rice University

Resolved

This incident has been resolved.
Posted Jun 25, 2025 - 21:34 CDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 25, 2025 - 19:45 CDT

Identified

Queued Internal and external email delivery is processing, and deliverability is improving after an initial fix. We are continuing to monitor.
Posted Jun 25, 2025 - 19:16 CDT

Update

We are continuing to investigate the issue with our service providers. Mail delivery is still significantly delayed for mail external to Rice.
Posted Jun 25, 2025 - 16:37 CDT

Investigating

We are currently investigating an issue with Proofpoint protection services, which is also impacting email delivery in and out of Rice.
Posted Jun 25, 2025 - 12:55 CDT
This incident affected: Email, Collaboration and Storage (Proofpoint Protection).