Intermittent Wi-Fi Connectivity

Incident Report for Rice University

Monitoring

We will continue to monitor the service closely throughout the evening and into tomorrow morning.
Posted Mar 24, 2026 - 18:10 CDT

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 24, 2026 - 17:45 CDT

Investigating

We are currently investigating reports of intermittent Wi-Fi connectivity affecting users in the following locations: Cambridge Office Building, Alice Pratt Brown Hall, Ley Student Center, McNair Hall, Anderson Biological Lab, and Rich Health Center. Users may experience frequent disconnections, slow speeds, or difficulty authenticating.
Posted Mar 24, 2026 - 15:02 CDT
This incident affects: Network and Connectivity (Wireless).