Canvas Login Blank Screen Issues
Incident Report for Rice University
Resolved
This incident has been resolved.
Posted Jan 15, 2019 - 11:39 CST
Monitoring
Some users are experiencing a blank page when they click on the Canvas Login Button that appears to be related to the brief network glitch this morning.  Clearing the cache in the browser resolves the browser issue.
Posted Jan 15, 2019 - 10:45 CST
This incident affected: Teaching and Learning (Canvas Learning Management System).