Exchange - issues connecting to OWA url for login
Incident Report for Rice University
Resolved
The fix implemented 9/4/19 about 19:45 seems to have resolved the issue with OWA. Resolving this incident.

Anyone experiencing an issue with OWA after this time, please log a ticket by sending email to "help@rice.edu" or call the Help Desk at 713.348.4357.
Posted Sep 05, 2019 - 15:08 CDT
Update
We completed some system changes tonight; 9/4/19 at approximately 19:45.

Testing for several users shows that the issue is Resolved. If your issue is still not resolved, please update any problem ticket, or contact the Help Desk at 713.348.4357 to let us know you are still experiencing the issue.

We will continue to monitor the situation.
Posted Sep 04, 2019 - 19:50 CDT
Update
We are continuing to monitor for issues. Please log a ticket at help.rice.edu or call 713.348.4357 if you are continuing to experience issues.
Posted Sep 03, 2019 - 09:40 CDT
Monitoring
A fix was implemented and we believe the issue is resolved. Users should restart all their browsers and attempt to access exchange.rice.edu again.
We will continue to monitor the situation
Posted Sep 03, 2019 - 09:37 CDT
Identified
Some users are seeing the error "exchange.rice.edu Too many redirects" when attempting to login via browser to URL: exchange.rice.edu/owa

Problem has been reported, and support is investigating.

Workaround:
Users can access Exchange accounts directly using their Outlook 2016 app.
Posted Aug 30, 2019 - 15:14 CDT
This incident affected: Email, Collaboration and Storage (Exchange Mail and Calendar).