Campus Network Outage | Power related
Incident Report for Rice University
Resolved
This incident has been resolved.
Posted Jan 16, 2023 - 13:17 CST
Investigating
We are currently seeing issues at Allen Center, Herzstein Hall, and Cohen House.
Posted Jan 16, 2023 - 10:26 CST
Update
The residual issues in Jones College and Baker Hall have been resolved.
Posted Jan 16, 2023 - 00:01 CST
Identified
Power has been restored to most of the campus. Network Services is currently investigating residual issues in Jones College and Baker Hall.

Cambridge Office Building and Huff House will return to service after power is restored.
Posted Jan 15, 2023 - 20:14 CST
Investigating
We are currently seeing issues with several buildings on campus that are experiencing a network outage. We will continue to monitor to make sure switches come back online after power is restored.
Posted Jan 15, 2023 - 15:49 CST
This incident affected: Network and Connectivity (Wireless, Wired).