Intermittent Email connection issues
Incident Report for Rice University
Resolved
This incident has been resolved.
Posted Feb 20, 2021 - 10:36 CST
Investigating
Intermittent Email connection issues have been reported; we have a fix in place and are monitoring
Posted Feb 19, 2021 - 11:00 CST
This incident affected: Email, Collaboration and Storage (Cyrus (Campus) Mail System, Rice Webmail).