Plotter 6 is not available. .
Incident Report for Rice University
Resolved
Plotter 6 maintenance has been completed and operational.
Posted Sep 11, 2019 - 13:41 CDT
Identified
Plotter 6 is located in the Mudd Building is out of service. The vendor has been notified.
Posted Sep 10, 2019 - 17:25 CDT
This incident affected: Teaching and Learning (OwlPrinting - Labs, Library).